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1. Introduction

Welcome to your StatView® 4.0 demonstration. After you use this program, we are sure that you 
will find that StatView 4.0 is by far the most versatile and easy-to-use, data analysis and 
presentation package available on any computer.

This document explains how to use StatView 4.0 demonstration software. Its purpose is to show 
how quickly and easily you can create datasets, perform statistical analyses, generate graphs and 
create presentations. This version of StatView 4.0 is a fully functional version of StatView with the 
following limitations:

• You cannot save datasets you create
• You can only save view documents in StatView 4.x view format. You cannot save them as

Text or PICT files.
• Datasets you create are limited to 25 rows and 25 columns 

(note: the retail version of StatView 4.0 can create datasets with up to 32,765 columns 
and over 2 billion rows)

• You cannot print a document
• You cannot paste from the StatView 4.0 clipboard into either the scrapbook or another 

application
• You can only open StatView 4.x format datasets

(note: the retail version of StatView 4.0 can also open StatView II, StatView 
SE+Graphics and SuperANOVA format datasets)

• Imported text files are limited to 25 rows and 25 columns
(note: the retail version of StatView 4.0 can create import data with up to 32,765 
columns and over 2 billion rows)

• Only ?? templates are included with this demo version. The full retail version ships with 
over 40 analysis and graph templates pre-made.

If you have any questions, please feel free to call Abacus Concepts Technical Support at (510) 
540-1949. You can also fax us at (510) 540-0260.

If you know of other people who would like to see first-hand how our software performs, you may 
copy your demonstration version of StatView 4.0 and this document for them. The StatView 4.0 
demonstration program and this document are not in the public domain. However, we allow you to
copy them for non-commercial use. 

System requirements 
To use StatView you need a Macintosh with the following:

• a minimum of 2 megabytes of main memory (RAM)
• Macintosh Operating System version 6.0.4 or later
• a hard disk

If you are running MultiFinder or Apple System 7, you may need additional main memory 
depending on your system settings. StatView is completely compatible with MultiFinder and 
System 7.



The StatView demo software contain two versions of the program: one which requires a floating-
point math coprocessor (FPU) and one which is designed to run without the FPU. The installation 
software determines which type of machine you have and installs the correct version for your 
Macintosh. You may also customize the installation to install a specific version.

2. StatView highlights
StatView is the first software package that offers in a single application all the tools that scientists
and researchers need to analyze and present their data. In the past, you first entered data into a 
spreadsheet program where you performed transformations or mathematical manipulations; the 
transformed data was then imported into a second application for statistical analysis; a third 
program was used to create graphs; and finally a drawing program was required to prepare tables
and graphs for presentation. Each of these transfers added time to your project, introduced the 
possibility of error, and forced you to learn separate applications. By allowing you to perform all 
these tasks inside one application, StatView can significantly decrease the time you spend on data 
analysis and presentation.

Unlike some integrated software, StatView is not four applications roughly spliced together. There
are no modules that you have to move between in order to use the program. StatView is a 
seamlessly integrated data analysis environment, designed so that all its features are at your 
fingertips at all times. And StatView’s innovative templates offer a graphical way to record the 
steps you use to analyze and present data so you do not have to repeat steps as you do your work. 

The sections below offer an introduction to many of StatView’s features.

Spreadsheet-like data management 
StatView’s data management give you full control over your data. Data is stored in a column/row 
format, like a spreadsheet. You have many options for customizing the appearance of the dataset: 
font, size, number of decimal places, etc. The dataset offers a wide variety of data types including 
real, integer, date/time, string, currencies, and more. And the variable attribute pane allows you to
view descriptive statistics for all your variables at any time and change the type and format of any 
column with a single click of the mouse.

StatView’s formula generator contains over 150 functions which can be used to create new 
variables using simple or complex mathematical, statistical, Boolean, and other expressions. If 
your original data columns change, formula-generated columns change accordingly. The formula 
generator also generates numerous series, distributions, and random numbers. You can also easily
explore your data by restricting an analyses to any user-defined subset of a dataset using the 
Criteria feature. 

Fully customizable graphs and tables
Graphs offered by the program include interaction bar, line, and point charts, pie charts, 
univariate and bivariate scattergrams and line charts, frequency distribution histograms, 
percentile plots, regression plots, box plots and more. You can add error bars to your graphs, 
using any error type you wish. Simple and polynomial regression lines and equations can be added
to scattergrams.

Every component of a graph is individually customizable, including the font and size of axis labels, 
point type, size, and color, bar or pie slice fills and color, the location and size of tick marks, graph 
frame style, and axis bounds. The exact dimensions of each graph can be specified to meet the 
requirements of any journal or report format. StatView also offers ten table formats and allows 
you to create your own table format as well.



A complete drawing environment
All output appears in our view window which has all the features of a drawing document and can 
cover as many pages as you wish. You can move drawn objects, text, graphs and tables to 
anywhere in this document. You can align objects to a grid or use rulers to precisely position your 
output. You can group objects together and position them in different layers.

The Draw menu offers sophisticated tools for adding embellishments to your output, such as 
arrows, rectangles, lines, splines, and more. You have complete control over color. Text of any font,
size, or style can be added anywhere in the view.

Broad-based statistics
Of course, StatView offers a comprehensive range of statistical analyses. From basic descriptive 
statistics to ANOVA and factor analysis, to a wide range of nonparametric tests. Each statistic 
offers you many options for specifying to exact detail the parameters of your analysis. And best of 
all there are no intimidating commands you have to learn to use a statistic. StatView’s expertly 
designed dialog boxes allow you to quickly and easily choose your statistical tests. This statistical 
breadth and ease of use has made StatView the most popular statistics package on the Macintosh.

Reduce your data analysis time
StatView contains additional features designed to minimize the time that you spend on the 
repetitive aspects of data analysis and presentation.

Templates
Templates are similar to batch programs or spreadsheet macros. They store complex series of 
instructions, which the program executes all at once in response to a single command. Unlike 
macros or batch programs however, templates are incredibly easy to create using StatView’s 
graphic interface. Templates retain every detail of an analysis, from the null hypothesis to the size 
of the tick marks on a graph. All these details are reproduced when you use a template to analyze 
new data. 

There are many ways to use templates to streamline your work. A supervisor or statistical 
consultant may set up a template tailored to a particular task. The work is done only once. After 
that, anyone can use the template - simply by specifying a new dataset and variables. Templates 
can also be used to speed the production of reports or journal articles that must meet standard 
requirements for figure size and appearance, font size and type, etc.

To use a template, you simply select it from the Analyze menu. All your specifications are 
reproduced with one click of the mouse. In addition, if you do not want to create your own 
templates, StatView comes with many ready-made templates which generate a wide variety of 
analyses and graphs. 

Action objects
All results, both tables and graphs, generated by StatView are action objects. This means they 
retain information about the steps that were required to generate them: the analysis and variable 
specifications. This information can be used to generate subsequent analyses without you having 
to specify the same information over again. Action objects significantly reduce the amount of time 
it takes to generate a series of related analyses.



Interactivity
All Abacus Concepts software is completely interactive. Results are dynamically linked to datasets 
so that any changes to your data are automatically reflected in results. Simply make the change to
your dataset, and StatView automatically recalculates your results. This feature makes it easy to 
perform “what-ifs” on data. It also means that once you have generated your graphs and tables, 
there is no need to repeat the whole process if you find a data error or want to eliminate a 
possible outlier. 

Hints
Help is available for most facets of the program. If you are running System 7, you can turn on 
balloon help and get information on each menu item, control, dialog box button and more. If you 
are running System 6, the same information is available in a floating hints window (which you can 
also use under System 7). If you are ever unclear about a program operation, you can simply open 
the hints window or turn on balloon help to discover how the program works.

Extensibility
Finally, StatView has been developed using the latest object-oriented technology allowing Abacus 
Concepts to deliver new program features to you as modular extensions. Instead of releasing an 
entirely new version, we can deliver a single extension to the program which, once placed in the 
Tools folder, will appear in the program. These extensions can be anything from new graphs and 
statistics to additional data management functions. We would like to here from you about the 
extensions to StatView that you would like to see.

3. StatView 4.0 Features
StatView is an integrated data analysis system, combining powerful graphing, drawing, 
spreadsheet-like data management tools and comprehensive statistical capabilities, all in a single 
application. All this functionality is accessible through StatView’s innovative, fast and easy-to-use 
analysis process.

Data management
StatView holds its data in a dataset, a spreadsheet format in which columns represent variables 
(such as gender, weight, height) and rows represent cases (such as patients in a medical study or 
plots in a field study). You can enter data by hand, or easily import it as a text file from another 
application. The Formula generator allows you to create variables using simple or complex 
arithmetic functions and generate various series or distributions. The dataset includes an attribute
pane, in which descriptive statistics for each variable can be accessed by a click of the mouse. You
will also find it easy to look at subsets of your data using criteria or splitting by different grouping 
variables.

View window
After entering or importing data, you are ready to perform analyses. All the results of your 
analyses are placed in a view. A single view can display tables and graphs from an unlimited 
number of analyses. A view can also simultaneously display results from different datasets. You 
can even combine variables from different datasets in a single analysis. You can save a view, with 
all its contents, and reopen it later for review or modification. The figure below shows the 



important features of a view.
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Analysis process
There are two ways to generate graphical and statistical analyses in StatView: choose a template 
(shipped with the program or created by you) using the Analyze menu, or create an analysis from 
scratch using the analysis browser and the variable browser.

Templates
Templates are similar to batch programs or spreadsheet macros in that they record your actions 
and store them as a series of instructions, which the program executes all at once in response to a
single command. You can customize a template to include frequently-used analyses along with 
extensive format specifications for graphs and tables. Templates are easy to create using 
StatView’s innovative graphic interface, but you may also use StatView’s ready-made templates to 
perform analyses without learning any other features of the program. In order to take full 
advantage of StatView’s potential, however, we recommend that you learn to create your own 
templates.

Analysis and variable browsers
The analysis and variable browsers are the tools you use to create analyses from scratch and to 
create templates. The analysis browser lists all analyses, both statistical and graphical, so you can 
create any analysis with two clicks of the mouse. Most analyses present a dialog box in which you 
set the parameters of the analysis (specify the null hypothesis, significance levels, etc.).

The variable browser allows you to assign variables to your analyses. This browser lists all the 
variables in any open datasets; you can use it to open additional datasets as well. Variables are 
assigned, just as analyses are created, with two clicks of the mouse. The variable browser also 
offers several options for the order in which variables appear in the browser and displays 
information about how variables are used in analyses. These features will help you to use StatView
effortlessly and efficiently.



Graphing and drawing
Once you have created results you can customize and embellish them for presentation or 
publication. A wide spectrum of plots is available to support your conclusions graphically. 
StatView also contains powerful formatting tools that give you extensive control over the style, 
position, size, pattern and color of every object in the view and of every component of graphs and 
tables. The view is a complete drawing environment. The tools in the Draw menu can be used to 
add drawn objects such as arrows and circles to emphasize important points in your results. You 
can also add text anywhere in the view.

The following exercises provide an introduction to all these features of StatView. 

4. Using StatView 4.0
The five exercises in this demonstration tutorial provide an introduction to the tools and concepts 
of StatView. In order to fully see the power of StatView we recommend that you follow the steps of
the tutorials at your computer. This tutorial will familiarize you with the range of capabilities 
available with StatView 4.0. The exercises are as follows:

1. Use a ready-made template and save results
2. Create a dataset and analysis from scratch and save your work as a template
3. Work with the template you created and customize graphs
4. Customize your results for presentation and publication
5. Manipulate your data using formula and criteria

Note: when you first launch StatView you will notice that a floating “hints” window appears in the 
middle of the screen. StatView provides extensive on-line help in this hints window. You may close 
this floating window at any time by clicking on the close box. You may make it visible again by 
choosing Hints from the Window (or ∑) menu.

Exercise 1: Use a template and save results
StatView is designed to be easy and quick to use. Templates are central to this goal. Templates can
be created to perform any combination of statistical or graphical analyses you wish, and they can 
contain detailed format specifications for the position, font, size, and other characteristics of the 
results. You do not have to make your own templates to use in StatView. There are many ready-
made templates that generate a wide variety of analyses and graphs. Before you learn to create 
your own templates, you will first learn to use these ready-made templates to analyze data.

Note that only a selection of the ready-made templates is initially installed in the Analyze menu. 
The remaining templates are in the StatView templates folder, which can be reached by choosing 
Templates from the Analyze menu. You can customize this menu yourself, as explained below. In 
addition, this demonstration version includes only a few of the templates that ship with the full 
retail version.

In this first exercise, you use a ready-made template to generate descriptive statistics and save 
your results. You will analyze four variables from the sample dataset Car Data. The dataset has 
information about weight, gas tank size, turning circle, horsepower and engine displacement for 
116 cars from different countries. You will generate descriptive statistics that will allow you to 
make comparisons among the cars from different countries.

• Open Car Data in the Sample Data folder. The dataset appears on the screen.
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• Notice the smaller window floating above the dataset. It is the variable browser, a 
floating window that shows a list of all variables in the dataset. When you select a 
variable from the variable browser and double-click on it (or click the Show button), 
that variable is selected in the dataset, which automatically scrolls so the variable’s 
column is visible in the window.

• Click the show/hide variable browser button in the upper right corner of the dataset. 
The variable browser is now hidden, and you can see more of the dataset. This button 
allows you to easily show or hide the variable browser at any time.

• Choose New View from the Analyze menu. An empty view appears on the screen.
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The analysis browser at the left of the view lists the statistical analyses and plots available in 
StatView. (Notice that the view also has a show/hide variable browser button in the upper right 
corner.) Since you will use a template to generate the analysis in this exercise, you will not use the
analysis browser.

• Close the analysis browser by double-clicking on the ∑ symbol at the bottom left of the 
screen. This maximizes the amount of space in which you can view your results.

Hide analysis and variable browsers
If you are operating StatView on a Macintosh with a small screen (Plus, SE, Classic, SE/30), you 
may want to use the program with the analysis and variable browsers initially hidden. This will 
give you more space in which to work. You can set the Application preferences by choosing 
Preferences from the Manage menu to show or hide these browsers on program startup. 

The default, as you have just seen, is to show both browsers. If you choose to hide them, the 
variable browser will remain hidden until you choose to show it by clicking the show/hide variable 
browser button. The analysis browser will remain closed until you drag on the resize symbol  to 
show it.



Use a template
• From the Analyze menu, choose Descriptive Statistics.

If Descriptive Statistics does not appear in the menu, choose Additional Templates 
instead. In the resulting dialog box, you can add any template to the Analyze menu by 
clicking in the check box to the right of the template’s name and clicking Change Menu.
You can use the Descriptive Statistics template directly from this dialog box by selecting
it and clicking Use Template.

• After you select a template, the Assign Variables dialog box appears.

• Click on the variable Horsepower in the list on the right. Drag to the “Variable(s)” slot 
on the left until the gray rectangle outline of the Horsepower variable appears in the 
slot.

Release the mouse. The horsepower variable is placed in the template slot.

• Double-click on the variable Weight. It is also added to the slot, directly below 
Horsepower. Notice that the slot grows to contain multiple variables.

• Click the OK button and the results of the template appear in the view:

Descriptive Statistics

130.198
39.822

3.697
116

55.000
278.000

0

2957.629
535.664
49.735

116
1695.000
4285.000

0

Mean
Std. Dev.
Std. Error
Count
Minimum
Maximum
# Missing

Horsepower Weight

You have just created your first analysis using StatView. Notice how little time it took and how 
easy it is to use a template to generate results.



Saving results
You can save your work at any time by saving the view. Remember that when you save a view in 
StatView, you are not simply saving the text or pictures of the output — you are saving all aspects 
of the work you have done. When you reopen the document, your work is as you left it, ready for 
you to pick up where you left off.

• Choose Save from the File menu. The directory dialog box appears.

• Name the view “Car Analysis” in the text box. Place the file in the Sample Data folder, 
and click Save.

• Close “Car Analysis” by choosing Close from the File menu.

• To re-open your work, choose Open from the File menu.

• Locate the file “Car Analysis” and click Open. This dialog box appears:

The most common use of this dialog box is to leave the default settings and click OK. The default 
settings tell StatView to use the original variables, from the original dataset(s) and place the 
output in a new view. Using these defaults will open a view with everything as you left it when the 
view was saved.

• Click OK.

The view reappears exactly as you left it. In fact, the program did not even have to recalculate 
your results. By default, all results are saved with a view. If your data has not changed, you can re-
open a view and get back to your analysis immediately. 

Note, this demonstration version does not allow you to save datasets. As a result, this exercise of 
saving a view and applying to the original dataset will only work with the sample StatView 4.0 
data shipped with this demonstration version.  Using the full retail version you will be able to 
create views and save them with any dataset you create. 

Before continuing on to the next example, close both Car Analysis and Car Data by choosing Close 
from the File menu. Note that you will want to close the view (Car Analysis) before closing the 
dataset. Do not save any changes to these documents.

Exercise 2: Create a dataset and analysis from scratch
In this exercise you create a dataset that contains two variables: a continuous variable and a 
nominal variable. You then use the analysis and variable browsers (rather than a template) to 
analyze your data by performing an unpaired t-test. Once the analysis is complete, you will save 
your work as a template for future use.

As you complete this exercise, you learn that the steps you take to generate results are the same 
ones you follow to create a template. With this knowledge you can decide how you would like to 
use StatView to analyze your data. You can use the analysis and variable browsers exclusively or 



templates exclusively, or a mixture of both. The choice is yours. We recommend that you create 
custom templates to take full advantage of StatView and meet your specific needs. As this exercise
shows, StatView makes this easy to do.

The attribute pane
• Choose New from the File menu. An empty dataset appears on the screen.
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Dataset 
row

Dataset 
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control (drag to 
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Show/hide 
Variable 
Browser 
button

Input cell

The rows above the body of the dataset contain attribute and summary information about the 
variable in the column below. Together, these rows are called the attribute pane, and you can show
or hide as many of the rows as you desire. In a new dataset, the first five rows of the attribute 
pane are visible. These contain pop-up menus for each of the five attributes of a variable: its data 
type (string, real, integer, date/time, etc.), its source (whether it was user entered or created using
a formula), its class (nominal, continuous, or informative), and the number of decimal places 
displayed (StatView carries 18 significant digits through all calculations and analyses; this 
attribute applies only to the way real numbers appear in the column). 

Create a dataset
First you will create a column (variable) containing continuous real data. The attribute pane shows
the Type and Class for each variable. The default Type and Class for input columns are Real and 
Continuous. These defaults are appropriate for this variable so you do not need to make any 
changes before you enter data into the column. An empty cell appears below the attribute pane. 
This is called the input cell.

• Click the mouse in the input cell to select it, and enter the number 3.2. Press Return.

When you enter a value in the input cell, a new input cell appears directly beneath it and a new 
input column appears to the right. In this way the dataset grows to include as many rows and 
columns as are necessary to accommodate your data.

• Enter the numbers 4, 5.8, 6, 12, 8.5, 5.5 and 10.3 in the column. Move down the column
using the Return key (or the Enter key if you are using a numeric keypad to enter data).

Now create the column containing the nominal grouping variable for the analysis.

• Use the Type pop-up menu in the attribute pane of the Input Column (the column to the 
right of Column 1) to change the variable’s Type to String. To do so, click on Real and 
when the pop-up menu appears, drag to String. Notice that the Class automatically 
changes to Nominal.



• Click in the top cell of the input column. Enter the values of the grouping variable as 
follows: Low, Low, High, Low, High, High, Low, High

Next you will name the two columns you have created and save the dataset.

• Select the name “Column 1” and type “Variable 1”. Use the Tab key to move to “Column
2” and type “Variable 2”. Click the mouse in another cell to enter the new variable 
names.

• Click on the  symbol between the two scroll bars on the right and drag down to 
expose the remaining rows in the attribute pane. You can examine descriptive 
information about the two columns you created.

• Double-click on the  symbol to hide all but the first five rows of the attribute pane. 
(Double-clicking a second time closes the entire attribute pane.)

Create your own analysis using the analysis and 
variable browsers
Now you will use the variable and analysis browsers to analyze the data and create a template.

• Choose New View from the Analyze menu. An empty view appears on the screen.

• In the analysis browser, select Unpaired Comparisons and click the Create Analysis 
button above the list.



A dialog box appears, allowing you to set the parameters for this analysis.

• The default dialog box settings, an unpaired t-test with an hypothesized difference of 0 
between group means, are appropriate, so click OK. Empty placeholder tables will 
appear in the view with the variable requirements for the analysis noted beneath them.

• If the variable browser is hidden, show it by clicking the show/hide variable browser 
button at the upper right of the view.

• In the variable browser, select Variable 1 and click the Add button. An X appears to the 
right of it, indicating that it is assigned to the analysis.

• Select Variable 2 and click the Add button. An G appears to the right of it, showing that 
it is assigned as a grouping variable in the analysis.



• An unpaired t-test table and a group information table appear in the view.

Unpaired t-test for Variable 1
Grouping Variable: Variable 2
Hypothesized Difference = 0

4.475 6 3.031 .0231
Mean Diff. DF t-Value P-Value

High, Low

Group Info for Variable 1
Grouping Variable: Variable 2

4 9.150 7.030 2.651 1.326
4 4.675 1.689 1.300 .650

Count Mean Variance Std. Dev. Std. Err
High
Low

You have just seen how easy it is to use the analysis and variable browser to perform analyses in 
StatView.

StatView is completely interactive
One of the unique features of StatView is that it is completely interactive. Any changes you make 
to the dataset, including the use of criteria (see Exercise 5), cause your results to recalculate 
automatically so the information in your results is always up-to-date. You do not have to start an 
analysis over from the beginning if you make a mistake or change a data value.

• Choose Untitled Dataset #1 from the Window ( or ∑ ) menu. Change the value in row 3 
from 5.8 to 7.8. Press Return or Enter. The rotating yin-yang symbol  indicates that 
the results are recalculating. In fact, whenever this symbol appears, you can cancel the 
current program operation by pressing Command ( ) -period.

• Choose Untitled View #1 from the Window menu to see the effect of this change on the 
results.

If you want to make many changes to your dataset, you may want to turn automatic recalculation 
off, by clicking in the Recalculate check box (or directly on the word “Recalculate”) in the upper 
left corner of the view.

Recheck the box after you have completed your changes, and results in the view will recalculate.



Save your analysis as a template
In a few steps, you created a template that performs an unpaired t-test on any set of data. You will 
now add this template to the Analyze menu for easy access.

• Choose Save from the File menu.

• Find and open the StatView Templates folder in the directory list. Name this file 
“Exercise Template” and click Save.

Note: you will see an alert recommending that you save the dataset before saving the 
view. Because you cannot save datasets with this demonstration version, simply click 
Continue and proceed with the following steps.

• From the Analyze menu, choose Additional Templates. Select Exercise Template in the 
scrolling list and click in the checkbox to its right.

• Click the Change Menu button. The template you created is now available for easy use 
through the Analyze menu.

• Close the Exercise Template and the Untitled Dataset #1. Do not save any changes that 
you have made.

Exercise 3: Work with templates and action objects
One common use of templates is for a supervisor or statistical consultant to set up a template 
tailored to a particular task. The work is done only once. After that, anyone can use the template, 
simply by specifying a new dataset and variables. You can also create a template to speed the 
production of reports or journal articles that must be meet standard requirements for figure size 
and appearance, font size and type, etc.

In this exercise, you will use the template you created in the last exercise and the analysis and 
variable browsers to generate tables and graphs. Finally, you will customize a graph.

Apply a template to new variables
First, make sure that all datasets and views from previous examples are closed.

• From the Analyze menu, choose Exercise Template. The directory dialog box appears 
for you to locate the dataset you wish to analyze.

• Locate Lipid Data in the Sample Data folder and click Open.

The Assign Variables dialog box appears for you to assign variables to the template.



Note that the order of template slots is not fixed. Either Variable 1 may appear on top (as pictured 
above) or Variable 2 may appear on top. Make sure that as you continue the exercise below you 
assign the variables to the correct slot. 

Hints
On-line help, in the form of a Hints window, is available for almost every feature of the program. 
Hints explain everything from the function of dialog box buttons to the buttons in the analysis and 
variable browsers. The Hints window is a valuable tool to help you understand how to use 
StatView. You will use Hints here to familiarize yourself with the use of the Assign Variables dialog
box.

• Choose Hints from the Window menu. The Hints window appears on the screen. It is a 
floating window that floats above all other StatView windows, including the browsers 
and dialog boxes.

• Click in the slot labeled “Variable 1” in the list on the left of the Assign Variables dialog 
box. The Hints window describes how the variable you drag into this slot will be used in
the view generated by this template. Select “Variable 2” to read a hint about its 
function in the template. Close the Hints window to get it out of the way. You may 
choose it from the Window menu any time to learn about the program.

You will now assign variables to the slots in the template. These variables contain data on the 
percent of ideal body weight of students before and after three years of medical school. 

• Drag the variable “% ideal body wt.” into the Variable 1 slot.

• Use the scrolling variable list to locate “% ideal body weight-3 yr”. Drag it into the 
Variable 1 slot as well. (You can also double-click on a variable to assign it to a slot. In 
addition, holding down the Command key and double-clicking allows you to control 
which slot variables go into.)

Since you assigned both variables to the same slot, they will be used identically in the analysis. 
When a template contains several variable slots, each slot represents one variable in the original 
view. As you assign a variable to a slot, it is used in all the places the original variable appeared. If
you assign two variables to one slot, then, everywhere the original variable was used there will 
now be two.



• Select the Variable 2 slot by clicking on it. Double-click on Gender in the variables list 
to assign it to the Variable 2 slot (the grouping variable in the analysis). Click OK.

A new view opens containing the results of the template. As you can see, four tables are 
generated, one pair for each continuous variable assigned.

.626 93 .195 .8460
Mean Diff. DF t-Value P-Value

male, female

Unpaired t-test for % ideal body wt.
Grouping Variable: Gender
Hypothesized Difference = 0

71 100.808 179.108 13.383 1.588
24 100.182 205.700 14.342 2.928

Count Mean Variance Std. Dev. Std. Err
male
female

Group Info for % ideal body wt.
Grouping Variable: Gender

-4.369 41 -.578 .5663
Mean Diff. DF t-Value P-Value

male, female

Unpaired t-test for % ideal weight-3yr
Grouping Variable: Gender
Hypothesized Difference = 0

38 102.968 162.446 12.745 2.068
5 107.336 1083.380 32.915 14.720

Count Mean Variance Std. Dev. Std. Err
male
female

Group Info for % ideal weight-3yr
Grouping Variable: Gender

Action objects and additional output
Now you will be introduced to another central feature of StatView: action objects. All output 
generated by the program, whether tables or graphs, are “action objects,” because they retain 
information about the variables and analysis parameters that define them, and contribute this 
information to subsequent analyses. When you click the Create Analysis button or assign a 
variable with the variable browser, StatView uses the attributes of the selected action object to 
determine what to do next, so you do not have to respecify all the information. An understanding 
of how action objects work is important for taking full advantage of the speed and ease with which
you can analyze data. 

To use action objects, you must be aware of which variables and results are currently selected. 
StatView provides several ways to monitor selection: (1)You can see the selection handles around 
selected results; (2) the Results Selected note in the upper right corner of the view reports the 
number of results selected; and (3) usage markers to the right of variables in the variable browser
reflect usage in the currently selected result.

A selected result Results Selected note Usage marker



In the view that you just generated, notice that the second set of tables is selected.

• Deselect the tables by clicking in any white (empty) space in the view. Select the first 
unpaired t-test table (Unpaired t-test for % ideal body wt.) by clicking on it so that only 
one action object is selected. Notice how the variable browser usage markers and the 
Results Selected note change as selection changes.

• In the analysis browser, click on the triangle next to Cell Plots. In the indented list that 
appears beneath it, double-click on Bar Chart (this has the same effect as clicking the 
Create Analysis button). The Cell Plot dialog box appears.

• The default settings are appropriate, so click OK. A graph appears with two bars, one 
for the mean of male body weight and one for the mean of female body weight.

The bar chart that appears in the view contains the same variables as the unpaired t-test table, yet
you did not have to assign variables for the second analysis. You can see that the bar chart visually
confirms the results of the unpaired t-test which indicate no significant difference between the 
means of male and female body weights.
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• Follow the same procedure to create a second bar chart for % ideal body weight - 3yr.

Next you will see how to use the information in action objects to quickly generate additional 
analyses for new variables.

Adding a variable to a selected table
You can assign additional variables to an analysis by selecting the result (table or graph) and using
the variable browser again.

• Deselect all output by clicking on any empty space in the view. You can confirm that 
nothing is selected by looking at the Results Selected note. It should be blank.

• Select the unpaired t-test or group info table for % ideal body wt. in order to access the 
information on the variables, analysis and parameters of these action objects.



Notice the usage markers in the variable browser next to the grouping variable (Gender) and the 
dependent variable (% ideal body wt.). You can see this information more conveniently if you 
change the display order for the variable browser to “by Usage.”

• Click on the Order pop-up menu and select “by Usage.” Notice that the variables 
currently being used by the selected analysis appear at the top of the browser.

.

• Select Cholesterol in the variable browser and click the Add button.

A new unpaired t-test is created combining the new continuous dependent variable Cholesterol 
with the original grouping variable Gender. You did not have to respecify either the analysis, its 
parameters, or the grouping variable.

Unpaired t-test for Cholesterol
Grouping Variable: Gender
Hypothesized Difference = 0

-4.540 93 -.537 .5926
Mean Diff. DF t-Value P-Value

male, female

Group Info for Cholesterol
Grouping Variable: Gender

71 190.085 1246.021 35.299 4.189
24 194.625 1392.940 37.322 7.618

Count Mean Variance Std. Dev. Std. Err
male
female

Notice that these two new tables are selected when they are created. The Results Selected note 
and the variable browser have updated to reflect this.

Split by
There are two ways you can easily examine results for subsets of your data. One is to use the 
Criteria feature, which is demonstrated in Exercise 5. Another is to use the Split By button in the 
variable browser. When you assign a nominal variable as a split-by variable, the results are 
generated for each group of the nominal variable. You will now use the Split By button to examine 
the effects of alcohol use on the body weight of male and female students in this study. 

• Select the % ideal body weight-3yr bar chart by clicking on it.

• In the variable browser, select “Alcohol use” and click the Split By button. The bar chart
changes to display bars for each level of alcohol use in the study group. The legend to 
the right of the graph identifies the levels of alcohol use by fill pattern in each bar. 
There are two missing bars (male >6 and females none), indicating that no subjects fall 
in those cells.
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While this example shows how to use the Split By button with graphs, you can just as easily use it 
with tables in order to see statistical tables broken down by the groups of a nominal variable. You 
can do all of this without having to re-order your dataset. You can apply a split-by variable to all 
the analyses generated in StatView.

Customizing bar charts
You access StatView’s many options for graph customization through the Edit Display button and 
the Draw menu. The graph above has several components that you can customize: axis intervals 
and labels, presence or absence of the legend and title, the frame, and the fill patterns for each of 
the bars.

You have to select an item in order to customize it. When a graph is first created, selection handles
appear around the border, indicating the whole graph is selected. You have access to the analysis 
parameters through the Edit Analysis button, and to the graph format through the Edit Display 
button.

The pattern in the bars can be changed by selecting the symbols in the legend (to the right of the 
graph) that show the fill patterns for each bar. A dotted line surrounds the one you select. The 
Draw menu has a pop-up menu of fill patterns to choose from.

Graph preferences
The default order in which fills are used for bars is one of the many global graph preferences you 
can set through the Preferences command in the Manage menu.

• Choose Preferences from the Manage menu.

• In the Preferences dialog box, select Graph and click the Modify button. The Graph 
Preferences dialog box appears.



This dialog box governs the default settings for all graphs. Any changes you make here affect 
every subsequent graph you create, but existing graphs will not change to conform to the new 
settings. 

Points, fills and colors for graphs are used in the order displayed in the dialog box. The bar fills of 
the graph you created match the order in the dialog box. The bar for the first variable uses the 
first fill, the bar for the second variable used the second fill, etc. You can change this default order
as follows:

• Place the cursor over the sixth fill . When you click, a palette of all fills appears as a 
pop-up menu. The current sixth fill is highlighted.

• Drag to the rectangle above the highlighted one  and release the mouse. The sixth 
fill in the dialog box is now  instead of . This order applies to all graphs you create 
from now on. The existing bar chart has not changed.

• Click OK in this dialog box, then click Done in the Choose Preferences dialog box to 
execute the new preferences.

You can change the fills in the existing chart directly through the Draw menu.

• With the plot selected, tear the Draw menu off the menu bar as follows:

Select the Draw menu, drag the cursor downwards. As you move the cursor off the 
border of the menu, a dotted outline of the Draw menu moves with the cursor. This 
outline indicates where the menu will appear when you release the mouse. Position the 
dotted outline so it does not block your view of the plot, and release the mouse.

The rectangle next to Fill says None, because no filled object is selected.

• Click in the legend on the filled square labeled “none”. The rectangle next to Fill 
displays the current fill for the selected variable.

• Click on the fill in the Draw menu to display the same palette of fills you saw in the 
Graph Preferences dialog box. This pop-up menu works the same way.

• Drag to the fill you selected earlier  and release the mouse. The rectangle next to 
fill changes, and the bar in the chart contains the new fill, as does the symbol in the 
legend.

This simple process for specifying fills applies to any area filled with a pattern. Fill patterns in 
graph backgrounds, plots (bars, pies, boxes), the legend and objects you draw in the view can all 
be customized in this way. Drawn objects have other aspects you can modify as well, as you will 
see in the next exercise.

You will now save the customizations you made to the analysis. You can save a view at any time. 
Remember that when you save a view in StatView, you are not simply saving the text or pictures of
the 



output — you are saving all aspects of the work you have done. When you reopen the document, 
your work is as you left it, and your document is still completely interactive.

Note: this demonstration version does not allow you to save datasets. As a result, this exercise of 
saving a view and applying to the original dataset will only work with the sample StatView 4.0 
data shipped with this demonstration version.  Using the full retail version you will be able to 
create views and save them with any dataset you create. 

• Choose Save from the File menu.

The dialog box that appears prompts you to name your document.

• Name this file Exercise 3 and place it in the Sample Data folder.

You may now continue to the next exercise to learn about further options for customizing the 
output using the Draw menu.

Exercise 4: Drawing and page layout for presentation.
StatView is designed to allow you to work through a project completely, from raw data to 
presentation, all in the same application. StatView’s drawing tools allow you to add those crucial 
finishing touches that can change a collection of tables and graphs into an informative (even 
entertaining) slide, poster, or report.

In this exercise, you will use the Draw menu to add drawn objects to the analysis you created in 
Exercise 3. Make sure that the view created in Exercise 3 is open and is the topmost window.

Drawing and text tools
• In the Draw menu, which should still be open, select the ellipse tool  by clicking on 

it.

• Position the cursor above and to the left of the left bar in the male bar group (males, 0 
drinks/week). Click and drag down and to the right, creating an ellipse that encircles all
the bars for males. Release the mouse when the ellipse is the desired size.

• In the Draw menu, select the line tool  by clicking on it. Position the cursor at the 
upper right edge of the ellipse and click and drag to draw a diagonal line up and to the 
right, where you will add a text explanation. If you have trouble positioning the line, you
may want to turn off the grid using the Turn Grid Off command located in the ruler 
portion of the Draw menu (or type Command-Y).

• In the Draw menu, select the text tool  by clicking on it. Position the cursor near the 
end of the line you drew, and click once. A text box containing a flashing cursor 
appears, indicating where the text you type will appear.

• Type “No obvious relationship between”, press Return and type “drinking and body 
weight.”

• In the Draw menu, select the arrow to return to a regular cursor, and click the close 
box of the menu.

• Select the text you added by clicking on it.



• In the Text menu, select Size and drag over and down in the pop-up menu to select 12. 
The text changes to 12 point type. You can change the font of the text in the same way, 
and move the text around or change the shape of the text box just as you repositioned 
the ellipse.

Clean up and printing
Since you can easily create so many different kinds of output, the number of objects in a view can 
be very large. StatView offers tools that you can use to find objects and organize their position and
alignment in the view. You may have generated multiple tables and graphs from different analyses,
and perhaps have experimented with placing them in different positions on the page. Before 
printing, you want to arrange the output neatly.

If you were to print the Exercise 3 view now, the second graph would be split between two pages. 
Scroll through the view to see that the graph is bisected by a page break, which looks like this:

You will want to use the Clean Up command to automatically reposition the analysis results away 
from page breaks. First, however, you must make sure that the drawing you added to the first 
graph will move with it when the objects in the view are moved.

• Select the drawing, the line, the text, and the graph by clicking and dragging the finger 
cursor  to surround them with a dotted line. When you release the mouse, check that
each of the four items is surrounded by selection handles. Choose Group from the 
Layout menu. Observe that the grouped objects are now surrounded by a single set of 
selection handles.

• From the Layout menu, choose Clean Up Items. The default settings in the dialog box 
are appropriate so click OK. The objects in the view are moved so that they do not 
overlap page breaks or each other.

Another tool used to manage multiple analyses in a view is the results browser, an index of the 
tables and graphs in all open views. If a view contains a great deal of output or you are working 
with several views at once, it is easy to lose track of what you have done, what is currently 
selected and where particular results are located. Using this index, you can select a result from 
the scrolling list, click the Select button, and the view scrolls to and selects the result.

The results browser presents several options for viewing results. If you order results by Location 
in the browser, you can see how many pages are in a document and which results are located on 
each page. You can then choose to print some or all pages, or to rearrange the output.

• Choose Results from the Window menu. The results browser appears.

• Use the Order pop-up menu to order the results by Location. You can see which results 
are on each page.



• Close the results browser using the close box in the upper left corner.

Hairlines
When printing to certain printers, you may wish to consider the use of hairline-width lines in 
tables and graphs. These can give your document a more professional look.

• From the Manage menu, choose Preferences. In the resulting dialog box, select View, 
and click Modify.

• Click the checkbox to “Print and copy results at 1/4 width.” You can also change the 
font and size of the type in tables and graphs here, but those changes will apply to 
future tables and graphs you create, not the existing ones. Click OK, then click Done in 
the next dialog box.

Once you set this 1/4 width preference, it applies to all documents you copy or print, regardless of 
whether you created them before or after you set the preference. No difference is visible on the 
screen. 

Now if this was the full retail version of the software you would be able to print this document by 
choosing Print from the File menu.

You will now save the customizations you made to the analysis.

• Choose Save from the File menu.

• Close the view and the Lipid Data.

Exercise 5: Data management
The exercises so far have shown you how to use StatView’s powerful statistical, graphics, and 
drawing features. This exercise introduces you to the last component of StatView’s functionality: 
data management. A powerful formula generator lets you apply a wide variety of statistical, 
logical, and mathematical functions to your data. You can create new variables using these 
functions and simple or complex combinations of existing variables.



StatView also includes functions that allow you to easily explore different portions of your data by 
defining criteria which restrict analyses to a user-specified subset of a dataset. This example will 
introduce you to the Formula and Criteria dialog boxes which give you access to these features of 
the program.

Formula dialog box
• Open Car Data from the Sample Data folder.

Scroll through the dataset to examine its contents. This dataset contains information on
116 cars produced in various countries. You will examine the relationship between the 
horsepower and weight of these cars, but first you must adjust the units in which car 
weights are reported. You will use the formula dialog box to change the values for 
weight from pounds to kilograms.

• Choose Formula from the Manage menu. The Formula dialog box appears.

The dialog box contains four main areas: the variables list in the upper left corner, the function list
in the lower left corner, the keypad at the lower right containing buttons for frequently used 
functions as well as a numeric keypad for adding numbers to formulae, and the formula definition 
area above the keypad where the formula is specified. By default, the function list is grouped by 
function type. Each function type has a triangle to its left. Click on the triangle in order to display 
the available functions for each type. You may also display all available functions in alphabetical 
order using the Order pop-up menu. 

• Double-click on Weight in the variable list. It appears in the definition area.

• Click on the “ /” symbol in the keypad. A division symbol is added to the formula.

• Use the numeric keypad to enter the value 2.2, the number of pounds in a kilogram. 
This value is added to the formula. The formula should read “Weight/2.2.”

• Name the new variable by clicking on the Attributes button at the bottom of the dialog 
box. Type “Weight (kg)” into the space following variable name and click OK to accept 
the default settings for the variable.

• Click Compute in the Formula dialog box. The dataset comes to the front and the values
of the new variable are calculated and placed in a new column labeled “Weight (kg).”

The formula definition is saved with the column when you save the dataset. You can check its 
accuracy or edit the formula at any time.

• Locate and select the column “Weight (kg)” in the dataset by clicking on the column 
name in the variable browser and clicking Show. (If the variable browser is not 
showing, click the show variable browser button to bring it to the front.)



• Make sure the attribute pane is open. If it is not, open it by double-clicking on the  
symbol at the right of the dataset.

Notice that the source entry in the column’s attribute pane is Dynamic Formula rather than User 
Entered. This means that the column was created using the formula dialog box and that its values 
are dynamically tied to values in other columns, in this case to the column “Weight”. If any values 
are changed in a column that is being used to specify a Dynamic Formula column, the values in 
the Dynamic Formula column automatically update.

• Click on Dynamic Formula in the attribute pane. The Formula dialog box appears, 
containing the formula specifications for the variable. You may edit any of the formula 
specifications in the dialog box.

• Close the Formula dialog box by clicking Cancel or the close box at the upper left.

Using a regression template
You will now use a template to generate a regression analysis, incorporating the formula-
generated variable you just created.

• In the Analyze menu, choose Templates. A dialog box appears for you to choose a 
template.

• In the Templates dialog box, select Regression-Simple and click the Use Template 
button. The Assign Variables dialog box appears.

• Drag the variable Weight (kg) into the Independent slot. Drag the variable Horsepower 
into the Dependent slot, and click OK.

You have created a regression analysis consisting of several tables of information and a 
scattergram. Notice that there is a strong positive linear relationship between the two variables, 
but the high degree of scatter in the data keeps the R2 relatively low. This analysis is a good 
candidate for a log transformation of the dependent variable since the plot of residuals vs the 
independent variable is cone-shaped. 

Customizing tables
Before you go on to use criteria, introduce yourself to some of the options for customizing tables 
and scattergrams.

• Scroll down to the Regression Coefficients table.

• Place the cursor between the headings Coefficients and Std. Err. until it changes to . 
Drag to the right to widen the column.

• Deselect the output by clicking in any white (empty) space in the view.

• Select the Regression Summary, ANOVA, and Regression Coefficients tables by holding 
down the Shift key and clicking on them.

• Click the Edit Display button. The Table dialog box appears.



• Click on the triangle in the Table format pop-up menu. Drag down to the fourth option 
and release the mouse.

• Click the Show button to see what this format looks like applied to the first table. 
Choose several different formats, clicking Show after each, to see how the various 
formats look on these tables. When you find one you like, click OK.

The Table dialog box now appears for the second (ANOVA) table. Format it as you did the first, 
Click OK, and go through the same process for the third table (Regression Coefficients).

Customizing scattergrams
• Click once in the interior of the Regression Plot (but not directly over a point) to select 

the graph. Small squares appear around the frame and the Results Selected note in the 
upper right corner of the view tells you one result is selected.

• Click the Edit Display button at the top of the view. The Graph dialog box appears, 
containing some of the formatting options for this graph.

• Click on the triangle in the Frame pop-up menu, drag to the L-shaped frame  and 
click OK.

• Click anywhere on the points in the scattergram to select the plot rather than the chart 
frame.

• In the Draw menu, click on the empty circle next to the word “point.” A pop-up menu of 
point types appears.



• Drag to the  symbol and release the mouse. The points in the regression plot change 
from empty circles to x’s.

• Close the Draw menu by clicking its close box.

Criteria
The next step is to use the Criteria dialog box to explore your data. You will create a criterion and 
apply it to this analysis.

• Choose Create Criteria from the Manage menu. The Criteria dialog box appears.

This dialog box contains three regions: the criteria name area (top), criteria definition area 
(middle), and the choices area (bottom). You will use the criteria name to apply the criterion, as 
you will see later. You will now create a criterion which restricts all calculations to cars produced 
in the U.S.

• First name the criterion by typing “United States” into the criteria name box.

• Double-click on Country in the variable list in the choices area. The variable appears in 
the criterion definition space, and the choices area changes to display a list of 
comparison operators.

• Double-click on the ? = ? operator in the choices area. An = sign appears to the right of 
the word Country in the definition area, and the choices area changes to display the 
available values for the variable Country.

• Double-click on the value USA in the choices area. The definition area should now read 
“Country = USA”. Click Save to save the criterion with the dataset for future use.

Bring the view you are working on to the front. Note the number and pattern of points in the 
regression plot and the parameters of the regression equation.



• Choose Edit/Apply Criteria from the Manage menu.

• Select the criterion United States from the list of criteria, and click Apply.

The analysis recalculates, now including only information for those cars manufactured in the U.S.

• Choose Car Data from the Window menu to see the effect of the criterion on the 
dataset.

The row numbers (on the far left of the dataset) are dimmed for the rows that contain information 
on cars not made in the U.S.

The Criteria pop-up menu at the top of the dataset should show the words “United States” to 
indicate that the criterion is in effect. The pop-up menu lists all the criteria that have been 
specified for a dataset. You can use the menu to easily and quickly toggle between various 
alternative criteria to explore their effects on the dataset and on your analysis. You can also use 
the “New” command in this pop-up menu to get access to the Create Criteria dialog box.

• Click on the  symbol between the two scroll bars on the right and drag down to 
expose the attribute pane. You can see descriptive information about each variable in 
the dataset.

• Choose No Criteria from the pop-up menu. Notice how all row numbers in the dataset 
become black, showing that all rows are now included in the analysis. The rotating yin-
yang symbol  shows that the results are recalculating. The attribute pane updates to 
display information about all rows in the dataset.

Close the view first and then the dataset without saving changes to either one.

5. Additional Information
This document covers only a sample of the variety of features you will find in StatView 4.0. Play 
around with the demonstration version to see the many capabilities of the program.

Importing to StatView
StatView can import data from text files. StatView’s import mechanism makes intelligent choices 
about how to place data into columns and how to fill in missing values. This is described in detail 
in the manual for the full version. One of the ways to try out StatView’s features is to import data 
that you have saved in text format. This demonstration version restricts importing to up to 25 rows
and 25 columns of your dataset.



Features disabled in this demonstration
The demonstration version you have does not allow you to save datasets, print datasets or views,  
and does not let you export your results to other programs. In addition, you cannot save views as 
either Text or PICT files. Also, you can only read StatView 4.x format files. In the full version of 
StatView 4.0, you can easily perform all these tasks. It is important to remember that the full 
StatView 4.0 will do these things since they are often vital to your work.

For more information
If you have any questions regarding this demonstration, the complete version of StatView 4.0, or 
any other software from Abacus Concepts, please call us at (510) 540-1949.

In Australia and New Zealand, please call PICA Software Pty., Ltd. at 61-3-3265255.

In Japan, please call HULINKS INC. +81-3-3590-2311.


